# CVE-2026-42358: Apache Airflow: Variable masker depth-limit bypass returns cleartext nested secrets

> Authenticated users can bypass secret masking to read plaintext nested secrets in Apache Airflow Variables if stored in deeply nested JSON structures.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-42358, ECHO-ce87-c209-0bd7, GHSA-33g2-gx67-c2h3, MINI-jj7p-xp2m-5xr5, MINI-wvpf-6jcg-mp82, PYSEC-2026-2343

## What is CVE-2026-42358?

CVE-2026-42358 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A bug in Apache Airflow's Variable response masker caused nested-key redaction (triggered by secret-suffixed key names like `password`, `token`, `secret`, `api_key`) to be bypassed when the JSON value's nesting depth exceeded the shared secrets masker's recursion limit: the masker returned the original nested item before checking the sensitive key name. An authenticated UI/API user with Variable read permission could harvest plaintext secret values stored under sensitive keys nested deep enough to exceed the masker's depth cap. Affects deployments that store sensitive values inside deeply-nested JSON Variables. This is a residual gap in the fix for CVE-2026-32690 (which covered shallower nesting via `max_depth=1`); the depth-limit boundary itself was not raised, so the same key-name bypass pattern reappears beyond the recursion cap. Users who already upgraded for CVE-2026-32690 should additionally upgrade to `apache-airflow` 3.2.2 or later to cover the deep-nesting path.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42358?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `airflow` | Bitnami | All versions | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-42358?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-42358 being exploited?

There is no known exploitation of CVE-2026-42358 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42358 and fix it if it is affected.

What it is: CVE-2026-42358 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42358 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- airflow (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42358/ (Markdown: https://insights.sbomify.com/CVE-2026-42358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42358
- OSV: https://osv.dev/vulnerability/CVE-2026-42358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42358/
Summaries are generated and may contain mistakes; the official description above is the record.
