# CVE-2026-42359: Apache Airflow: Authenticated RCE via XCom PATCH endpoint — XComUpdateBody missing FORBIDDEN_XCOM_KEYS validator

> Authenticated users with XCom write permissions can achieve remote code execution on the triggerer by bypassing input validation on the PATCH endpoint.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-42359, CLEANSTART-2026-NE51066, ECHO-8570-1636-eec1, GHSA-wr76-29cr-67w8, MINI-2p25-gwpq-2h5m, PYSEC-2026-185

## What is CVE-2026-42359?

CVE-2026-42359 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A bug in Apache Airflow's XCom PATCH endpoint `PATCH /api/v2/xcomEntries/{key}` allowed an authenticated UI/API user with XCom write permission on a Dag to set XCom entries under reserved key names (e.g. `return_value`) that the matching POST endpoint already validated against `FORBIDDEN_XCOM_KEYS`. The endpoint also accepted serialized payload shapes the triggerer's deserializer treats as code; combined, this allowed RCE on the triggerer when the affected task next deferred. Affects deployments where untrusted users have XCom write permission on Dags that defer to the triggerer. This is a fix-bypass of CVE-2026-33858: PR #64148 added the `FORBIDDEN_XCOM_KEYS` validator only on the POST/set path; the PATCH path was not covered. Users who already upgraded for CVE-2026-33858 should additionally upgrade to `apache-airflow` 3.2.2 or later to cover the PATCH-path bypass.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-42359?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `airflow` | Bitnami | From 3.2.0 | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-42359?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-42359 being exploited?

There is no known exploitation of CVE-2026-42359 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42359 and fix it if it is affected.

What it is: CVE-2026-42359 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42359 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- airflow (Bitnami): affected from 3.2.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42359/ (Markdown: https://insights.sbomify.com/CVE-2026-42359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42359
- OSV: https://osv.dev/vulnerability/CVE-2026-42359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42359/
Summaries are generated and may contain mistakes; the official description above is the record.
