# CVE-2026-42360: Apache Airflow: Rendered template truncation bypasses nested sensitive-key masking

> Authenticated users can read unmasked sensitive keys in rendered templates if field length exceeds limits, exposing secrets like passwords and tokens.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** BIT-airflow-2026-42360, CLEANSTART-2026-QQ72344, ECHO-9b9a-e7b8-0e09, GHSA-cg3x-89rc-x9mw, MINI-g5j7-g2c4-qqcq, MINI-m4h2-9fmm-rvgm, PYSEC-2026-172

## What is CVE-2026-42360?

CVE-2026-42360 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A bug in Apache Airflow's rendered-template field handling caused nested sensitive-key masking (e.g. nested `password` / `token` / `secret` / `api_key` keys inside a JSON template structure) to be bypassed when the rendered field exceeded `[core] max_templated_field_length`: Airflow stringified the structure before redaction, losing the nested key context, and persisted the plaintext value into `rendered_fields`. An authenticated UI/API user with permission to read rendered template fields could harvest secret values intended to be masked. Affects deployments where Dag authors pass structured JSON to operators with nested sensitive keys. This is a variant of `CWE-200` previously addressed for the user-registered `mask_secret()` patterns in CVE-2025-68438; that fix did not cover the nested sensitive-keyword allowlist. Users who already upgraded for CVE-2025-68438 should additionally upgrade to `apache-airflow` 3.2.2 or later to cover the nested-key path.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42360?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `apache-airflow` | PyPI | All versions | 3.2.2 |
| `airflow` | Bitnami | All versions | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-42360?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-42360 being exploited?

There is no known exploitation of CVE-2026-42360 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42360 and fix it if it is affected.

What it is: CVE-2026-42360 is a medium-severity vulnerability in Apache Airflow, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42360 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- apache-airflow (PyPI): affected all versions; fixed in 3.2.2
- airflow (Bitnami): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42360/ (Markdown: https://insights.sbomify.com/CVE-2026-42360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42360
- OSV: https://osv.dev/vulnerability/CVE-2026-42360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42360/
Summaries are generated and may contain mistakes; the official description above is the record.
