# CVE-2026-4240: Open5GS CCA smf_s6b_sta_cb denial of service


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-wq9j-47c8-8fpr

## What is CVE-2026-4240?

CVE-2026-4240 is a medium-severity vulnerability in Open5gs Open5gs, published on 16 Mar 2026. 

### Official description

A vulnerability was determined in Open5GS up to 2.7.6. The affected element is the function smf_gx_cca_cb/smf_gy_cca_cb/smf_s6b_aaa_cb/smf_s6b_sta_cb of the component CCA Handler. This manipulation causes denial of service. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.7.7 is sufficient to fix this issue. Patch name: 80eb484a6ab32968e755e628b70d1a9c64f012ec. Upgrading the affected component is recommended.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2026-4240?

It affects 1 product.


Products: Open5gs Open5gs.

## How do I fix CVE-2026-4240?

No fix has been published for CVE-2026-4240 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-4240 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4240 exists.

## Other vulnerabilities in Open5gs Open5gs

- [CVE-2024-40130](https://insights.sbomify.com/CVE-2024-40130/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-28122](https://insights.sbomify.com/CVE-2021-28122/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-25863](https://insights.sbomify.com/CVE-2021-25863/): Hardcoded credentials in n/a (high 8.8)
- [CVE-2025-41067](https://insights.sbomify.com/CVE-2025-41067/): Reachable Assertion vulnerability in Open5GS (high 8.7)
- [CVE-2025-41068](https://insights.sbomify.com/CVE-2025-41068/): Reachable Assertion vulnerability in Open5GS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4240 and fix it if it is affected.

What it is: CVE-2026-4240 is a medium-severity vulnerability in Open5gs Open5gs, published on 16 Mar 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4240 exists.

Affected product: Open5gs Open5gs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4240/ (Markdown: https://insights.sbomify.com/CVE-2026-4240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4240
- OSV: https://osv.dev/vulnerability/CVE-2026-4240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4240/
Summaries are generated and may contain mistakes; the official description above is the record.
