# CVE-2026-42403: Apache Neethi: Circular Policy Reference Infinite Loop

> Attackers can cause denial of service in applications using Apache Neethi by submitting policy documents with circular references, triggering infinite loops or stack overflows.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2026
- **Updated:** 1 May 2026
- **Also known as:** CLEANSTART-2026-DE70000, CLEANSTART-2026-LX82916, CLSA-2026-1784682823, CLSA-2026-1793138734, CLSA-2026-1793138829, ECHO-9f6b-0e44-5961, GHSA-2hfh-9h53-qc24

## What is CVE-2026-42403?

CVE-2026-42403 is a high-severity denial of service vulnerability in Apache Neethi, published on 1 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Neethi does not properly detect circular references in policy definitions. When a WS-Policy document contains circular policy references (where Policy A references Policy B which references Policy A), the policy normalization process can enter an infinite loop or cause excessive recursion, leading to a stack overflow or application hang. An attacker can craft malicious policy documents with circular references to cause a Denial of Service condition

Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-42403?

2 open source packages ship an affected version, including org.apache.neethi:neethi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.neethi:neethi` | Maven | All versions | 3.2.2 |
| `org.apache.neethi:neethi` | Maven | All versions | 3.2.2 |

Products: Apache Neethi.

## How do I fix CVE-2026-42403?

Upgrade org.apache.neethi:neethi to 3.2.2 or later.

## Is CVE-2026-42403 being exploited?

There is no known exploitation of CVE-2026-42403 in the wild and no public exploit code.

## Other vulnerabilities in Apache Neethi

- [CVE-2026-91863](https://insights.sbomify.com/CVE-2026-91863/): Apache Neethi: Uncontrolled recursion while parsing crafted WS-Policy documents allows denial of service (high 7.5)
- [CVE-2026-91864](https://insights.sbomify.com/CVE-2026-91864/): Apache Neethi: Crafted WS-Policy documents bypass element/attribute limits causing memory exhaustion (high 7.5)
- [CVE-2026-91865](https://insights.sbomify.com/CVE-2026-91865/): Apache Neethi: Crafted policy references cause exponential expansion during normalization leading to denial of service (high 7.5)
- [CVE-2026-91866](https://insights.sbomify.com/CVE-2026-91866/): Apache Neethi: Crafted policies cause unbounded work during intersection leading to denial of service (high 7.5)
- [CVE-2026-66142](https://insights.sbomify.com/CVE-2026-66142/): Apache Neethi: Uncontrolled recursion in policy processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42403 and fix it if it is affected.

What it is: CVE-2026-42403 is a high-severity denial of service vulnerability in Apache Neethi, published on 1 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42403 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.neethi:neethi (Maven): affected all versions; fixed in 3.2.2
- org.apache.neethi:neethi (Maven): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42403/ (Markdown: https://insights.sbomify.com/CVE-2026-42403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42403
- OSV: https://osv.dev/vulnerability/CVE-2026-42403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42403/
Summaries are generated and may contain mistakes; the official description above is the record.
