CVE-2026-42422 OpenClaw < 2026.4.8 - Role Bypass in device.token.rotate Function
Attackers can bypass role approval checks to mint tokens for unauthorized roles and scopes in OpenClaw.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42422?
CVE-2026-42422 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.4.8 contains a role bypass vulnerability in the device.token.rotate function that allows minting tokens for unapproved roles. Attackers can bypass device role-upgrade pairing to preserve or mint roles and scopes that had not undergone intended approval.
Weakness: CWE-863
Which versions are affected by CVE-2026-42422?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.8 |
openclaw npm | All versions | 2026.4.8 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-42422?
Upgrade openclaw to 2026.4.8 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-42422 being exploited?
There is no known exploitation of CVE-2026-42422 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-whf9-3hcx-gq54, MINI-wgm5-jh77-8fmc.