CVE-2026-42423 OpenClaw < 2026.4.8 - strictInlineEval Approval Boundary Bypass via Approval-Timeout Fallback
Attackers can bypass strictInlineEval approval requirements via timeout fallback to execute inline eval commands on OpenClaw hosts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42423?
CVE-2026-42423 is a high-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.4.8 contains an approval-timeout fallback mechanism that bypasses strictInlineEval explicit-approval requirements on gateway and node exec hosts. Attackers can exploit this timeout fallback to execute inline eval commands that should require explicit user approval, circumventing the intended security boundary.
Weakness: CWE-636
Which versions are affected by CVE-2026-42423?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.8 |
openclaw npm | All versions | 2026.4.8 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-42423?
Upgrade openclaw to 2026.4.8 or later.
Is CVE-2026-42423 being exploited?
There is no known exploitation of CVE-2026-42423 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-q2gc-xjqw-qp89, MINI-x236-pvfx-qq39.