# CVE-2026-42429: OpenClaw < 2026.4.8 - Privilege Escalation via Gateway Plugin HTTP Authentication

> Attackers can escalate read permissions to write access via the gateway plugin, allowing unauthorized modification of runtime operations.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-4f8g-77mw-3rxc, MINI-48mw-599h-mr63

## What is CVE-2026-42429?

CVE-2026-42429 is a medium-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw before 2026.4.8 contains a privilege escalation vulnerability in the gateway plugin HTTP authentication mechanism that escalates identity-bearing operator.read requests to runtime operator.write permissions. Attackers can exploit this by sending read-scoped requests through the gateway auth route to gain unauthorized write access to runtime operations.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42429?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.4.8 |
| `openclaw` | npm | All versions | 2026.4.8 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-42429?

Upgrade openclaw to 2026.4.8 or later.

## Is CVE-2026-42429 being exploited?

There is no known exploitation of CVE-2026-42429 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42429 and fix it if it is affected.

What it is: CVE-2026-42429 is a medium-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42429 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.4.8
- openclaw (npm): affected all versions; fixed in 2026.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42429/ (Markdown: https://insights.sbomify.com/CVE-2026-42429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42429
- OSV: https://osv.dev/vulnerability/CVE-2026-42429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42429/
Summaries are generated and may contain mistakes; the official description above is the record.
