# CVE-2026-42434: OpenClaw 2026.4.5 < 2026.4.10 - Sandbox Escape via host Parameter Override in Exec Routing

> Attackers can bypass sandbox restrictions by overriding exec routing parameters, allowing unauthorized code execution on remote nodes.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-736r-jwj6-4w23, MINI-mhmj-6xw4-4x57

## What is CVE-2026-42434?

CVE-2026-42434 is a high-severity vulnerability in OpenClaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw versions 2026.4.5 before 2026.4.10 contain a sandbox escape vulnerability allowing sandboxed agents to override exec routing by specifying host=node. Attackers can bypass sandbox boundaries and route execution to remote nodes instead of intended sandbox paths.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42434?

2 open source packages ship an affected version, including openclaw.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.4.5 | 2026.4.10 |
| `openclaw` | npm | From 2026.4.5 | 2026.4.10 |

## How do I fix CVE-2026-42434?

Upgrade openclaw to 2026.4.10 or later.

## Is CVE-2026-42434 being exploited?

There is no known exploitation of CVE-2026-42434 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42434 and fix it if it is affected.

What it is: CVE-2026-42434 is a high-severity vulnerability in OpenClaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42434 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.4.5; fixed in 2026.4.10
- openclaw (npm): affected from 2026.4.5; fixed in 2026.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42434/ (Markdown: https://insights.sbomify.com/CVE-2026-42434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42434
- OSV: https://osv.dev/vulnerability/CVE-2026-42434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42434/
Summaries are generated and may contain mistakes; the official description above is the record.
