CVE-2026-42435 OpenClaw 2026.2.22 < 2026.4.12 - Shell-Wrapper Detection Bypass via Environment Variable Assignment Injection

High 8.7 Published Updated

Attackers can bypass shell-wrapper detection by injecting environment variables, potentially manipulating execution semantics and security controls in OpenClaw.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42435?

CVE-2026-42435 is a high-severity command injection vulnerability in OpenClaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenClaw versions from 2026.2.22 before 2026.4.12 contain an insufficient shell-wrapper detection vulnerability allowing attackers to inject environment variable assignments at the argv level. Attackers can bypass exec preflight handling to manipulate high-risk shell variables like SHELLOPTS and PS4, affecting execution semantics and security controls.

Weakness: CWE-184

Which versions are affected by CVE-2026-42435?

2 open source packages ship an affected version, including openclaw.

PackageAffectedFixed in
openclaw npmFrom 2026.2.222026.4.12
openclaw npmFrom 2026.2.222026.4.12

How do I fix CVE-2026-42435?

Upgrade openclaw to 2026.4.12 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-42435 being exploited?

There is no known exploitation of CVE-2026-42435 in the wild and no public exploit code.

Sources

Also known as GHSA-j6c7-3h5x-99g9, MINI-8mw4-xhxg-c8g3.

Is CVE-2026-42435 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free