{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of CVE-2026-42435 in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.4.12 or later.","what":"CVE-2026-42435 is a high-severity command injection vulnerability in OpenClaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42435 and fix it if it is affected.\n\nWhat it is: CVE-2026-42435 is a high-severity command injection vulnerability in OpenClaw, published on 5 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42435 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected from 2026.2.22; fixed in 2026.4.12\n- openclaw (npm): affected from 2026.2.22; fixed in 2026.4.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42435/ (Markdown: https://insights.sbomify.com/CVE-2026-42435/index.md)","id":"CVE-2026-42435","markdown":"https://insights.sbomify.com/CVE-2026-42435/index.md","name":"CVE-2026-42435","record":{"aliases":["GHSA-j6c7-3h5x-99g9","MINI-8mw4-xhxg-c8g3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenClaw security library","requires_auth":"low_privilege","summary":"Attackers can bypass shell-wrapper detection by injecting environment variables, potentially manipulating execution semantics and security controls in OpenClaw.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"OpenClaw versions from 2026.2.22 before 2026.4.12 contain an insufficient shell-wrapper detection vulnerability allowing attackers to inject environment variable assignments at the argv level. Attackers can bypass exec preflight handling to manipulate high-risk shell variables like SHELLOPTS and PS4, affecting execution semantics and security controls.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenClaw 2026.2.22 \u003c 2026.4.12 - Shell-Wrapper Detection Bypass via Environment Variable Assignment Injection","id":"CVE-2026-42435","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenClaw \u003c 2026.4.14 - Internal Page Content Exposure via Browser Snapshot and Screenshot Routes","id":"CVE-2026-42436"},"packages":[{"ecosystem":"npm","fixed":["2026.4.12"],"introduced":["2026.2.22"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-j6c7-3h5x-99g9"},{"ecosystem":"npm","fixed":["2026.4.12"],"introduced":["2026.2.22"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-j6c7-3h5x-99g9"}],"prev":{"headline":"OpenClaw 2026.4.5 \u003c 2026.4.10 - Sandbox Escape via host Parameter Override in Exec Routing","id":"CVE-2026-42434"},"products":["OpenClaw"],"published":"2026-05-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-06","vendors":["OpenClaw"]},"summary":"Attackers can bypass shell-wrapper detection by injecting environment variables, potentially manipulating execution semantics and security controls in OpenClaw.","url":"https://insights.sbomify.com/CVE-2026-42435/"}