CVE-2026-42437 OpenClaw 2026.4.9 < 2026.4.10 - Denial of Service via Oversized WebSocket Frames in Voice-call Realtime Path

High 8.2 Published Updated

Remote attackers can cause service unavailability by sending oversized WebSocket frames to the voice-call realtime path in OpenClaw.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-42437?

CVE-2026-42437 is a high-severity denial of service vulnerability in OpenClaw, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw versions 2026.4.9 before 2026.4.10 contain a denial of service vulnerability in the voice-call realtime WebSocket path that accepts oversized frames without proper validation. Remote attackers can send oversized WebSocket frames to cause service unavailability for deployments exposing the voice-call realtime WebSocket path.

Weakness: CWE-770

Which versions are affected by CVE-2026-42437?

2 open source packages ship an affected version, including openclaw.

PackageAffectedFixed in
openclaw npmFrom 2026.4.92026.4.10
openclaw npmFrom 2026.4.92026.4.10

How do I fix CVE-2026-42437?

Upgrade openclaw to 2026.4.10 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-42437 being exploited?

There is no known exploitation of CVE-2026-42437 in the wild and no public exploit code.

Sources

Also known as GHSA-vw3h-q6xq-jjm5, MINI-c5mp-3xvc-rrf7.

Is CVE-2026-42437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free