# CVE-2026-42437: OpenClaw 2026.4.9 < 2026.4.10 - Denial of Service via Oversized WebSocket Frames in Voice-call Realtime Path

> Remote attackers can cause service unavailability by sending oversized WebSocket frames to the voice-call realtime path in OpenClaw.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-vw3h-q6xq-jjm5, MINI-c5mp-3xvc-rrf7

## What is CVE-2026-42437?

CVE-2026-42437 is a high-severity denial of service vulnerability in OpenClaw, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw versions 2026.4.9 before 2026.4.10 contain a denial of service vulnerability in the voice-call realtime WebSocket path that accepts oversized frames without proper validation. Remote attackers can send oversized WebSocket frames to cause service unavailability for deployments exposing the voice-call realtime WebSocket path.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-42437?

2 open source packages ship an affected version, including openclaw.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.4.9 | 2026.4.10 |
| `openclaw` | npm | From 2026.4.9 | 2026.4.10 |

## How do I fix CVE-2026-42437?

Upgrade openclaw to 2026.4.10 or later.

## Is CVE-2026-42437 being exploited?

There is no known exploitation of CVE-2026-42437 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42437 and fix it if it is affected.

What it is: CVE-2026-42437 is a high-severity denial of service vulnerability in OpenClaw, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42437 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.4.9; fixed in 2026.4.10
- openclaw (npm): affected from 2026.4.9; fixed in 2026.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42437/ (Markdown: https://insights.sbomify.com/CVE-2026-42437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42437
- OSV: https://osv.dev/vulnerability/CVE-2026-42437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42437/
Summaries are generated and may contain mistakes; the official description above is the record.
