# CVE-2026-42440: Apache OpenNLP: OOM DoS via Unbounded Array Allocation in AbstractModelReader

> Attacker can cause denial of service via crafted model file triggering out-of-memory error in Apache OpenNLP library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 30 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-42440, GHSA-659w-93r5-9j6m, UBUNTU-CVE-2026-42440

## What is CVE-2026-42440?

CVE-2026-42440 is a high-severity denial of service vulnerability in Apache OpenNLP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OOM Denial of Service via Unbounded Array Allocation in Apache OpenNLP AbstractModelReader 

Versions Affected: 

before 1.9.5
before 2.5.9

before 3.0.0-M3 

Description:

The AbstractModelReader methods getOutcomes(), getOutcomePatterns(), and getPredicates() each read a 32-bit signed integer count field from a binary model stream and pass that value directly to an array allocation (new String[numOutcomes], new int[numOCTypes][], new String[NUM_PREDS]) without validating that the value is non-negative or within a reasonable bound. The count is therefore fully attacker-controlled when the model file originates from an untrusted source.

A crafted .bin model file in which any of these count fields is set to Integer.MAX_VALUE (or any value large enough to exhaust the available heap) triggers an OutOfMemoryError at the array allocation itself, before the corresponding label or pattern data is consumed from the stream. The error occurs very early in deserialization: for a GIS model, getOutcomes() is reached after only the model-type string, the correction constant, and the correction parameter have been read; so the attacker pays no meaningful size cost to weaponize a payload, and a single small file can crash a JVM that loads it. Any code path that deserializes a .bin model is affected, including direct use of GenericModelReader and any higher-level component that delegates to it during model load.

The practical impact is denial of service against processes that load model files from untrusted or semi-trusted origins.  

Mitigation:

  *  2.x users should upgrade to 2.5.9.

  *  3.x users should upgrade to 3.0.0-M3.

Note: The fix introduces an upper bound on each of the three count fields, checked before array allocation; counts that are negative or exceed the bound cause an IllegalArgumentException to be thrown and the read to fail fast with no large allocation. The default bound is 10,000,000, which is well above the entry counts of legitimate OpenNLP models but far below any value that would threaten heap exhaustion. Deployments that legitimately need to load models with more entries than the default can raise the limit at JVM startup by setting the OPENNLP_MAX_ENTRIES system property to the desired positive integer (e.g. -DOPENNLP_MAX_ENTRIES=50000000); invalid or non-positive values fall back to the default.

Users who cannot upgrade immediately should treat all .bin model files as untrusted input unless their provenance is verified, and should avoid loading models supplied by end users or fetched from third-party repositories without integrity checks.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-42440?

4 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.opennlp:opennlp-tools` | Maven | All versions | 2.5.9 |
| `org.apache.opennlp:opennlp-tools` | Maven | All versions | 2.5.9 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 3.0.0-M1 | 3.0.0-M3 |
| `org.apache.opennlp:opennlp-tools` | Maven | From 3.0.0-M1 | 3.0.0-M3 |

Products: Apache Opennlp.

## How do I fix CVE-2026-42440?

Upgrade org.apache.opennlp:opennlp-tools to a fixed version for your release line: 2.5.9 or 3.0.0-M3.

## Is CVE-2026-42440 being exploited?

There is no known exploitation of CVE-2026-42440 in the wild and no public exploit code.

## Other vulnerabilities in Apache OpenNLP

- [CVE-2026-82617](https://insights.sbomify.com/CVE-2026-82617/): Apache OpenNLP, Apache OpenNLP: ReDoS / stack exhaustion in RegexNameFinderFactory built-in EMAIL and URL patterns (critical 10.0)
- [CVE-2026-42027](https://insights.sbomify.com/CVE-2026-42027/): Apache OpenNLP: Arbitrary Class Instantiation via Model Manifest in ExtensionLoader (critical 9.8)
- [CVE-2017-12620](https://insights.sbomify.com/CVE-2017-12620/): Improper Restriction of XML External Entity Reference in Apache OpenNLP (critical 9.8)
- [CVE-2026-40682](https://insights.sbomify.com/CVE-2026-40682/): Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor (critical 9.1)
- [CVE-2026-67211](https://insights.sbomify.com/CVE-2026-67211/): Apache OpenNLP: OOM DoS via Unbounded Array Allocation in SymSpellModelSerializer (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42440 and fix it if it is affected.

What it is: CVE-2026-42440 is a high-severity denial of service vulnerability in Apache OpenNLP, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42440 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.opennlp:opennlp-tools (Maven): affected all versions; fixed in 2.5.9
- org.apache.opennlp:opennlp-tools (Maven): affected all versions; fixed in 2.5.9
- org.apache.opennlp:opennlp-tools (Maven): affected from 3.0.0-M1; fixed in 3.0.0-M3
- org.apache.opennlp:opennlp-tools (Maven): affected from 3.0.0-M1; fixed in 3.0.0-M3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42440/ (Markdown: https://insights.sbomify.com/CVE-2026-42440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42440
- OSV: https://osv.dev/vulnerability/CVE-2026-42440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42440/
Summaries are generated and may contain mistakes; the official description above is the record.
