# CVE-2026-42447: jadx: HTML Injection in Summary panel

> Attackers can inject HTML into jadx-gui via malicious APKs, enabling IP disclosure or local application interaction.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-jwv3-q635-w9m4

## What is CVE-2026-42447?

CVE-2026-42447 is a low-severity cross-site scripting vulnerability in skylot jadx, published on 14 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

jadx is a Dex to Java decompiler. Prior to 1.5.6, jadx-gui is affected by an HTML injection vulnerability in the Summary tab because SummaryNode.java appends arches and perArchCount values derived from .so file path components inside an APK into an HTML panel without escaping. A malicious APK with an HTML URL-encoded ZIP entry name can force rendering of arbitrary HTML, perform out-of-band requests, disclose the victim IP address, or interact with locally exposed applications. This issue is fixed in version 1.5.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42447?

It affects 1 product.


Products: Jadx Project Jadx.

## How do I fix CVE-2026-42447?

No fix has been published for CVE-2026-42447 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42447 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42447 exists.

## Other vulnerabilities in skylot jadx

- [CVE-2022-0219](https://insights.sbomify.com/CVE-2022-0219/): Improper Restriction of XML External Entity Reference in skylot/jadx (medium 5.5)
- [CVE-2022-39259](https://insights.sbomify.com/CVE-2022-39259/): Jadx-gui subject to Denial of Service via Swing HTML rendering (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42447 and fix it if it is affected.

What it is: CVE-2026-42447 is a low-severity cross-site scripting vulnerability in skylot jadx, published on 14 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42447 exists.

Affected product: skylot jadx. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42447/ (Markdown: https://insights.sbomify.com/CVE-2026-42447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42447
- OSV: https://osv.dev/vulnerability/CVE-2026-42447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42447/
Summaries are generated and may contain mistakes; the official description above is the record.
