CVE-2026-42449 n8n-MCP: IPv4-mapped IPv6 addresses bypass SSRF protection in validateUrlSync(), enabling full SSRF for SDK embedders
Attacker-supplied URLs bypass SSRF checks via IPv4-mapped IPv6, allowing access to internal services and metadata in SDK embedders.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42449?
CVE-2026-42449 is a high-severity server-side request forgery vulnerability in czlonkowski n8n-mcp, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n-MCP is an MCP server that provides AI assistants access to n8n node documentation, properties, and operations. In versions 2.47.4 through 2.47.13, the SDK embedder path (N8NDocumentationMCPServer constructor, getN8nApiClient(), and validateInstanceContext()), the synchronous URL validator in SSRFProtection.validateUrlSync() had no IPv6 checks. IPv4-mapped IPv6 addresses such as http://[::ffff:169.254.169.254] bypassed the cloud-metadata, localhost, and private-IP range checks. An attacker able to supply an n8nApiUrl value could cause the server to issue HTTP requests to cloud metadata endpoints, RFC1918 private networks, or localhost services. Response bodies are returned to the caller (non-blind SSRF), and the n8nApiKey is forwarded in the x-n8n-api-key header to the attacker-controlled target. Projects with deployments embedding n8n-mcp as an SDK using N8NDocumentationMCPServer or N8NMCPEngine with user-supplied InstanceContext are affected. The first-party HTTP server deployment was not primarily affected — it has a second async validator (validateWebhookUrl) that catches IPv6 addresses. This issue has been fixed in version 2.47.14. If users are unable to upgrade immediately as a workaround they can validate URLs before passing to the SDK, restrict egress at the network layer, and reject user-controlled n8nApiUrl values.
Weakness: CWE-918
Which versions are affected by CVE-2026-42449?
2 open source packages ship an affected version, including n8n-mcp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n-mcp npm | From 2.47.4 | 2.47.14 |
n8n-mcp npm | From 2.47.4 | 2.47.14 |
Products include N8n-Mcp N8n-Mcp.
How do I fix CVE-2026-42449?
Upgrade n8n-mcp to 2.47.14 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-42449 being exploited?
There is no known exploitation of CVE-2026-42449 in the wild and no public exploit code.
Other vulnerabilities in czlonkowski n8n-mcp
- CVE-2026-54052 n8n-MCP: Cross-tenant access to workflow version backups in multi-tenant HTTP deployments
- CVE-2026-39974 n8n-MCP has an Authenticated SSRF via instance-URL header in multi-tenant HTTP mode
- CVE-2026-45707 n8n-MCP: Multi-tenant MCP requests fall back to process-level n8n credentials when tenant headers are absent or incomplete
- CVE-2026-44694 n8n-MCP: Authenticated SSRF in n8n-mcp webhook and API client paths
- CVE-2026-45582 n8n-MCP: Workflow telemetry sanitizer could retain partial values from URL-shaped node parameters
Sources
Also known as GHSA-56c3-vfp2-5qqj.