{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-42457 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-42457 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-42457 is a critical cross-site scripting vulnerability in loft-sh loft, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42457 and fix it if it is affected.\n\nWhat it is: CVE-2026-42457 is a critical cross-site scripting vulnerability in loft-sh loft, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-42457 in the wild and no public exploit code.\n\nAffected product: loft-sh loft. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42457/ (Markdown: https://insights.sbomify.com/CVE-2026-42457/index.md)","id":"CVE-2026-42457","markdown":"https://insights.sbomify.com/CVE-2026-42457/index.md","name":"CVE-2026-42457","record":{"aliases":["GHSA-x7cq-v3h6-426c"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes platform","requires_auth":"low_privilege","summary":"Stored XSS in vCluster Platform allows attackers to execute scripts and escalate privileges to Global-Admin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"vCluster Platform: Stored XSS can lead to privilege escalation","id":"CVE-2026-42457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Magento LTS: Reflected XSS - Import -\u003e Data Flow (profiles)","id":"CVE-2026-42458"},"packages":[],"prev":{"headline":"AnythingLLM: Cross-User TTS Audio Disclosure via Chat ID (IDOR)","id":"CVE-2026-42456"},"products":["loft"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["loft-sh"]},"summary":"Stored XSS in vCluster Platform allows attackers to execute scripts and escalate privileges to Global-Admin.","url":"https://insights.sbomify.com/CVE-2026-42457/"}