# CVE-2026-42457: vCluster Platform: Stored XSS can lead to privilege escalation

> Stored XSS in vCluster Platform allows attackers to execute scripts and escalate privileges to Global-Admin.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-x7cq-v3h6-426c

## What is CVE-2026-42457?

CVE-2026-42457 is a critical cross-site scripting vulnerability in loft-sh loft, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42457?


## How do I fix CVE-2026-42457?

No fix has been published for CVE-2026-42457 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42457 being exploited?

There is no known exploitation of CVE-2026-42457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42457 and fix it if it is affected.

What it is: CVE-2026-42457 is a critical cross-site scripting vulnerability in loft-sh loft, published on 14 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42457 in the wild and no public exploit code.

Affected product: loft-sh loft. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42457/ (Markdown: https://insights.sbomify.com/CVE-2026-42457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42457
- OSV: https://osv.dev/vulnerability/CVE-2026-42457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42457/
Summaries are generated and may contain mistakes; the official description above is the record.
