{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42458 exists.","fix":"Upgrade openmage/magento-lts to 20.18.0 or later.","what":"CVE-2026-42458 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 15 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42458 and fix it if it is affected.\n\nWhat it is: CVE-2026-42458 is a medium-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 15 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42458 exists.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42458/ (Markdown: https://insights.sbomify.com/CVE-2026-42458/index.md)","id":"CVE-2026-42458","markdown":"https://insights.sbomify.com/CVE-2026-42458/index.md","name":"CVE-2026-42458","record":{"aliases":["GHSA-x8jv-q8j2-487c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento LTS","requires_auth":"none","summary":"Reflected XSS in Magento LTS admin panel allows attackers to execute scripts in admin sessions, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-87","name":"Improper Neutralization of Alternate XSS Syntax"}],"description":"Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, there is a reflected XSS vulnerability under admin panel -\u003e System -\u003e Import/Export -\u003e Dataflow - Profiles. This vulnerability is fixed in 20.18.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Magento LTS: Reflected XSS - Import -\u003e Data Flow (profiles)","id":"CVE-2026-42458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Free5GC UDM has Improper Input Validation and Generation of Error Messages Containing Sensitive Information","id":"CVE-2026-42459"},"packages":[{"ecosystem":"Packagist","fixed":["20.18.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-x8jv-q8j2-487c"},{"ecosystem":"Packagist","fixed":["20.18.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-x8jv-q8j2-487c"}],"prev":{"headline":"vCluster Platform: Stored XSS can lead to privilege escalation","id":"CVE-2026-42457"},"products":["magento-lts"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["OpenMage"]},"summary":"Reflected XSS in Magento LTS admin panel allows attackers to execute scripts in admin sessions, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-42458/"}