# CVE-2026-42461: Arcane Vulnerable to Unauthenticated Disclosure of Custom Compose Template Content (incl. `.env` secrets)

> Unauthenticated attackers can read sensitive environment variables and secrets from custom Docker Compose templates due to missing authorization on API endpoints.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-cxx3-hr75-4q96, GO-2026-5340

## What is CVE-2026-42461?

CVE-2026-42461 is a high-severity missing authorization vulnerability in getarcaneapp arcane, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Arcane is an interface for managing Docker containers, images, networks, and volumes. Prior to version 1.18.0, four GET endpoints under /api/templates* in Arcane's Huma backend are registered without any Security requirement, allowing any unauthenticated network client to list and read the full Compose YAML and .env content of every custom template stored in the instance. Because Arcane's UI exposes a "Save as Template" flow on the project / swarm-stack creation pages that persists the operator's real env content (database passwords, API keys, etc.) verbatim, this missing authorization is an unauthenticated read of operator secrets in practice — not a theoretical info-disclosure. The frontend explicitly treats /customize/templates/* as an authenticated area (PROTECTED_PREFIXES in frontend/src/lib/utils/redirect.util.ts), and every CRUD operation (POST/PUT/DELETE) on the same paths requires a Bearer/API key, so this is a clear backend authorization gap, not intended public access. This issue has been patched in version 1.18.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-42461?

3 open source packages ship an affected version, including github.com/getarcaneapp/arcane/backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getarcaneapp/arcane/backend` | Go | All versions | 1.18.0 |
| `github.com/getarcaneapp/arcane/backend` | Go | All versions | 1.18.0 |
| `github.com/getarcaneapp/arcane/backend` | Go | All versions | 1.18.0 |

Products: Getarcane Arcane.

## How do I fix CVE-2026-42461?

Upgrade github.com/getarcaneapp/arcane/backend to 1.18.0 or later.

## Is CVE-2026-42461 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42461 exists.

Public exploit code:

- Arcane < 1.18.0 - Unauthenticated Template and Env Disclosure (nuclei): http/cves/2026/CVE-2026-42461.yaml

## Other vulnerabilities in getarcaneapp arcane

- [CVE-2026-40242](https://insights.sbomify.com/CVE-2026-40242/): Arcane Unauthenticated SSRF with Conditional Response Reflection in Template Fetch Endpoint (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42461 and fix it if it is affected.

What it is: CVE-2026-42461 is a high-severity missing authorization vulnerability in getarcaneapp arcane, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42461 exists.

Affected packages and fixed versions:
- github.com/getarcaneapp/arcane/backend (Go): affected all versions; fixed in 1.18.0
- github.com/getarcaneapp/arcane/backend (Go): affected all versions; fixed in 1.18.0
- github.com/getarcaneapp/arcane/backend (Go): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42461/ (Markdown: https://insights.sbomify.com/CVE-2026-42461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42461
- OSV: https://osv.dev/vulnerability/CVE-2026-42461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42461/
Summaries are generated and may contain mistakes; the official description above is the record.
