# CVE-2026-42498: Apache Tomcat: WebSocket authentication header exposure

> Apache Tomcat exposes HTTP authentication headers to unexpected hosts during WebSocket authentication, allowing attackers to read sensitive credentials.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** BIT-tomcat-2026-42498, CLEANSTART-2026-BN96016, CLEANSTART-2026-YT48250, DEBIAN-CVE-2026-42498, GHSA-fv25-8xcx-gqjc, MINI-p237-63jj-h6g6, ROOT-APP-MAVEN-CVE-2026-42498, UBUNTU-CVE-2026-42498

## What is CVE-2026-42498?

CVE-2026-42498 is a high-severity vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of HTTP Authentication Header to unexpected hosts during WebSocket authentication vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.2 through 9.0.117, from 8.5.24 through 8.5.100, from 7.0.83 through 7.0.109.

Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118, which fix the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-42498?

19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.22 |
| `tomcat` | Bitnami | From 10.0.0 | 10.1.55, 11.0.22, 9.0.118 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat-catalina` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat:tomcat-catalina` | Maven | All versions | 9.0.118 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.22 |

Products: Apache Tomcat.

## How do I fix CVE-2026-42498?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 9.0.118, 10.1.55 or 11.0.22.

## Is CVE-2026-42498 being exploited?

There is no known exploitation of CVE-2026-42498 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42498 and fix it if it is affected.

What it is: CVE-2026-42498 is a high-severity vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42498 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected all versions; fixed in 9.0.118
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected all versions; fixed in 9.0.118
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- tomcat (Bitnami): affected from 10.0.0; fixed in 10.1.55, 11.0.22, 9.0.118
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 9.0.118
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 9.0.118
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42498/ (Markdown: https://insights.sbomify.com/CVE-2026-42498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42498
- OSV: https://osv.dev/vulnerability/CVE-2026-42498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42498/
Summaries are generated and may contain mistakes; the official description above is the record.
