CVE-2026-42509 Apache Wicket: crafted strings can break out of the JavaScript sequence
Attackers can inject malicious scripts via crafted strings in Apache Wicket, potentially executing code in user browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-42509?
CVE-2026-42509 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-42509?
6 open source packages ship an affected version, including org.apache.wicket:wicket-parent. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.wicket:wicket-parent Maven | From 10.0.0-M1 | 10.9.0 |
org.apache.wicket:wicket-parent Maven | From 10.0.0-M1 | 10.9.0 |
org.apache.wicket:wicket-parent Maven | From 8.0.0-M1 to 8.17.0 | None |
org.apache.wicket:wicket-parent Maven | From 8.0.0-M1 to 8.17.0 | None |
org.apache.wicket:wicket-parent Maven | From 9.0.0-M1 to 9.22.0 | None |
org.apache.wicket:wicket-parent Maven | From 9.0.0-M1 to 9.22.0 | None |
Products include Apache Wicket.
How do I fix CVE-2026-42509?
Upgrade org.apache.wicket:wicket-parent to 10.9.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-42509 being exploited?
There is no known exploitation of CVE-2026-42509 in the wild and no public exploit code.
Other vulnerabilities in Apache Wicket
- CVE-2024-36522 Apache Wicket: Remote code execution via XSLT injection
- CVE-2026-40010 Apache Wicket: possible session fixation using AuthenticatedWebSession
- CVE-2016-6793 Deserialization in n/a
- CVE-2016-6806 Apache Wicket vulnerable to CSRF attacks
- CVE-2026-71257 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed
Sources
Also known as GHSA-5x9h-93gp-chpj.