# CVE-2026-42509: Apache Wicket: crafted strings can break out of the JavaScript sequence

> Attackers can inject malicious scripts via crafted strings in Apache Wicket, potentially executing code in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-5x9h-93gp-chpj

## What is CVE-2026-42509?

CVE-2026-42509 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42509?

6 open source packages ship an affected version, including org.apache.wicket:wicket-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket-parent` | Maven | From 10.0.0-M1 | 10.9.0 |
| `org.apache.wicket:wicket-parent` | Maven | From 10.0.0-M1 | 10.9.0 |
| `org.apache.wicket:wicket-parent` | Maven | From 8.0.0-M1 to 8.17.0 | None |
| `org.apache.wicket:wicket-parent` | Maven | From 8.0.0-M1 to 8.17.0 | None |
| `org.apache.wicket:wicket-parent` | Maven | From 9.0.0-M1 to 9.22.0 | None |
| `org.apache.wicket:wicket-parent` | Maven | From 9.0.0-M1 to 9.22.0 | None |

Products: Apache Wicket.

## How do I fix CVE-2026-42509?

Upgrade org.apache.wicket:wicket-parent to 10.9.0 or later.

## Is CVE-2026-42509 being exploited?

There is no known exploitation of CVE-2026-42509 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42509 and fix it if it is affected.

What it is: CVE-2026-42509 is a medium-severity cross-site scripting vulnerability in Apache Wicket, published on 6 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42509 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket-parent (Maven): affected from 10.0.0-M1; fixed in 10.9.0
- org.apache.wicket:wicket-parent (Maven): affected from 10.0.0-M1; fixed in 10.9.0
- org.apache.wicket:wicket-parent (Maven): affected from 8.0.0-M1 up to 8.17.0; no fix listed
- org.apache.wicket:wicket-parent (Maven): affected from 8.0.0-M1 up to 8.17.0; no fix listed
- org.apache.wicket:wicket-parent (Maven): affected from 9.0.0-M1 up to 9.22.0; no fix listed
- org.apache.wicket:wicket-parent (Maven): affected from 9.0.0-M1 up to 9.22.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42509/ (Markdown: https://insights.sbomify.com/CVE-2026-42509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42509
- OSV: https://osv.dev/vulnerability/CVE-2026-42509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42509/
Summaries are generated and may contain mistakes; the official description above is the record.
