{"answers":{"affected":"3 open source packages ship an affected version, including ironic. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42510 in the wild and no public exploit code.","fix":"Upgrade ironic to 35.0.1 or later.","what":"CVE-2026-42510 is a medium-severity command injection vulnerability in OpenStack Ironic, published on 28 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42510 and fix it if it is affected.\n\nWhat it is: CVE-2026-42510 is a medium-severity command injection vulnerability in OpenStack Ironic, published on 28 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42510 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ironic (PyPI): affected all versions; fixed in 35.0.1\n- ironic (PyPI): affected all versions; fixed in 35.0.1\n- ironic (PyPI): affected all versions; fixed in 35.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42510/ (Markdown: https://insights.sbomify.com/CVE-2026-42510/index.md)","id":"CVE-2026-42510","markdown":"https://insights.sbomify.com/CVE-2026-42510/index.md","name":"CVE-2026-42510","record":{"aliases":["DEBIAN-CVE-2026-42510","GHSA-wqpv-c3pp-3m58","PYSEC-2026-2525","UBUNTU-CVE-2026-42510"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenStack Ironic","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary commands via ipmitool in OpenStack Ironic when the console interface is enabled in non-default configurations.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ironic","vendor":"openstack"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere","id":"CVE-2026-42510","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Remote code execution via malicious DHCP options","id":"CVE-2026-42511"},"packages":[{"ecosystem":"PyPI","fixed":["35.0.1"],"introduced":["0"],"last_affected":[],"package":"ironic","purl":null,"source":"GHSA-wqpv-c3pp-3m58"},{"ecosystem":"PyPI","fixed":["35.0.1"],"introduced":["0"],"last_affected":[],"package":"ironic","purl":"pkg:pypi/ironic","source":"GHSA-wqpv-c3pp-3m58"},{"ecosystem":"PyPI","fixed":["35.0.1"],"introduced":["0"],"last_affected":[],"package":"ironic","purl":"pkg:pypi/ironic","source":"PYSEC-2026-2525"}],"prev":{"headline":"Apache Wicket: crafted strings can break out of the JavaScript sequence","id":"CVE-2026-42509"},"products":["Ironic"],"published":"2026-04-28","related":[{"cvss_score":7.7,"headline":"OpenStack Ironic has an Incorrect Resource Transfer Between Spheres","id":"CVE-2026-42997","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":6.5,"headline":"Information disclosure in n/a","id":"CVE-2015-7514","kev_date_added":null,"published":"2017-06-07"},{"cvss_score":5.9,"headline":"OpenStack Ironic allows file overwrite via directory traversal during deployment with a crafted ISO image","id":"CVE-2026-48681","kev_date_added":null,"published":"2026-06-04"},{"cvss_score":5.8,"headline":"OpenStack Ironic allows Boot Script Injection","id":"CVE-2026-46447","kev_date_added":null,"published":"2026-06-03"},{"cvss_score":5.3,"headline":"OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash","id":"CVE-2026-50589","kev_date_added":null,"published":"2026-06-04"},{"cvss_score":4.9,"headline":"Path traversal in Ironic","id":"CVE-2026-44917","kev_date_added":null,"published":"2026-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-20","vendors":["OpenStack"]},"summary":"Attackers can execute arbitrary commands via ipmitool in OpenStack Ironic when the console interface is enabled in non-default configurations.","url":"https://insights.sbomify.com/CVE-2026-42510/"}