# CVE-2026-42510: OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

> Attackers can execute arbitrary commands via ipmitool in OpenStack Ironic when the console interface is enabled in non-default configurations.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 20 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-42510, GHSA-wqpv-c3pp-3m58, PYSEC-2026-2525, UBUNTU-CVE-2026-42510

## What is CVE-2026-42510?

CVE-2026-42510 is a medium-severity command injection vulnerability in OpenStack Ironic, published on 28 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-42510?

3 open source packages ship an affected version, including ironic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic` | PyPI | All versions | 35.0.1 |
| `ironic` | PyPI | All versions | 35.0.1 |
| `ironic` | PyPI | All versions | 35.0.1 |

Products: Openstack Ironic.

## How do I fix CVE-2026-42510?

Upgrade ironic to 35.0.1 or later.

## Is CVE-2026-42510 being exploited?

There is no known exploitation of CVE-2026-42510 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Ironic

- [CVE-2026-42997](https://insights.sbomify.com/CVE-2026-42997/): OpenStack Ironic has an Incorrect Resource Transfer Between Spheres (high 7.7)
- [CVE-2015-7514](https://insights.sbomify.com/CVE-2015-7514/): Information disclosure in n/a (medium 6.5)
- [CVE-2026-48681](https://insights.sbomify.com/CVE-2026-48681/): OpenStack Ironic allows file overwrite via directory traversal during deployment with a crafted ISO image (medium 5.9)
- [CVE-2026-46447](https://insights.sbomify.com/CVE-2026-46447/): OpenStack Ironic allows Boot Script Injection (medium 5.8)
- [CVE-2026-50589](https://insights.sbomify.com/CVE-2026-50589/): OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42510 and fix it if it is affected.

What it is: CVE-2026-42510 is a medium-severity command injection vulnerability in OpenStack Ironic, published on 28 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42510 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic (PyPI): affected all versions; fixed in 35.0.1
- ironic (PyPI): affected all versions; fixed in 35.0.1
- ironic (PyPI): affected all versions; fixed in 35.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42510/ (Markdown: https://insights.sbomify.com/CVE-2026-42510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42510
- OSV: https://osv.dev/vulnerability/CVE-2026-42510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42510/
Summaries are generated and may contain mistakes; the official description above is the record.
