# CVE-2026-42523: Jenkins GitHub Plugin has an XSS vulnerability

> Stored XSS in Jenkins GitHub Plugin allows attackers with Read permission to execute scripts via job URLs, potentially compromising user accounts.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-w22p-4x9f-486v

## What is CVE-2026-42523?

CVE-2026-42523 is a critical cross-site scripting vulnerability in Jenkins GitHub Plugin, published on 29 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature "GitHub hook trigger for GITScm polling", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42523?

2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.46.0.1 |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.46.0.1 |

Products: Jenkins Github.

## How do I fix CVE-2026-42523?

Upgrade com.coravy.hudson.plugins.github:github to 1.46.0.1 or later.

## Is CVE-2026-42523 being exploited?

There is no known exploitation of CVE-2026-42523 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins GitHub Plugin

- [CVE-2018-1000600](https://insights.sbomify.com/CVE-2018-1000600/): CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials (high 8.8)
- [CVE-2018-1000183](https://insights.sbomify.com/CVE-2018-1000183/): Jenkins GitHub Plugin exposure of sensitive information vulnerability exists (medium 6.5)
- [CVE-2023-46650](https://insights.sbomify.com/CVE-2023-46650/): Stored XSS vulnerability in Jenkins GitHub Plugin (medium 5.4)
- [CVE-2018-1000184](https://insights.sbomify.com/CVE-2018-1000184/): Jenkins GitHub Plugin server-side request forgery vulnerability exists (medium 5.4)
- [CVE-2022-36885](https://insights.sbomify.com/CVE-2022-36885/): Jenkins GitHub plugin uses weak webhook signature function (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42523 and fix it if it is affected.

What it is: CVE-2026-42523 is a critical cross-site scripting vulnerability in Jenkins GitHub Plugin, published on 29 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42523 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.46.0.1
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.46.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42523/ (Markdown: https://insights.sbomify.com/CVE-2026-42523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42523
- OSV: https://osv.dev/vulnerability/CVE-2026-42523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42523/
Summaries are generated and may contain mistakes; the official description above is the record.
