# CVE-2026-42524: Jenkins HTML Publisher Plugin has a XSS vulnerability in the legacy wrapper file

> Stored XSS in Jenkins HTML Publisher Plugin allows attackers with Item/Configure permission to execute scripts via job names or URLs.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-f8h4-46xv-h7jj

## What is CVE-2026-42524?

CVE-2026-42524 is a high-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 29 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins HTML Publisher Plugin 427 and earlier does not escape job name and URL in the legacy wrapper file, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42524?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:htmlpublisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | All versions | 427.1 |
| `org.jenkins-ci.plugins:htmlpublisher` | Maven | All versions | 427.1 |

Products: Jenkins Html Publisher.

## How do I fix CVE-2026-42524?

Upgrade org.jenkins-ci.plugins:htmlpublisher to 427.1 or later.

## Is CVE-2026-42524 being exploited?

There is no known exploitation of CVE-2026-42524 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins HTML Publisher Plugin

- [CVE-2024-28149](https://insights.sbomify.com/CVE-2024-28149/): Jenkins HTML Publisher Plugin does not properly sanitize input (medium 6.5)
- [CVE-2018-1000175](https://insights.sbomify.com/CVE-2018-1000175/): Jenkins HTML Publisher Plugin path traversal vulnerability (medium 6.5)
- [CVE-2025-53651](https://insights.sbomify.com/CVE-2025-53651/): Jenkins HTML Publisher Plugin vulnerability displays controller file system information in its logs (medium 6.3)
- [CVE-2019-10432](https://insights.sbomify.com/CVE-2019-10432/): Jenkins HTML Publisher Plugin vulnerable to Cross-site Scripting (medium 5.4)
- [CVE-2024-28150](https://insights.sbomify.com/CVE-2024-28150/): Jenkins HTML Publisher Plugin Stored XSS vulnerability (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42524 and fix it if it is affected.

What it is: CVE-2026-42524 is a high-severity cross-site scripting vulnerability in Jenkins HTML Publisher Plugin, published on 29 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42524 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 427.1
- org.jenkins-ci.plugins:htmlpublisher (Maven): affected all versions; fixed in 427.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42524/ (Markdown: https://insights.sbomify.com/CVE-2026-42524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42524
- OSV: https://osv.dev/vulnerability/CVE-2026-42524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42524/
Summaries are generated and may contain mistakes; the official description above is the record.
