# CVE-2026-42526: Apache Airflow Amazon provider: Prevent unauthorized access to team-scoped secrets in AWS Secrets Manager and SSM Parameter Store backends

> A privileged caller without team context can retrieve another team's secrets by crafting a colliding connection ID in the experimental multi-tenant feature.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** CLEANSTART-2026-GE58327, ECHO-3e07-2829-3520, GHSA-g9qc-qf28-hhqx, MINI-4rgh-qjq4-v8pr, MINI-jfvr-vcgq-7m6m, PYSEC-2026-595

## What is CVE-2026-42526?

CVE-2026-42526 is a medium-severity missing authorization vulnerability in Apache Airflow Amazon provider, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In the AWS Secrets Manager and SSM Parameter Store secrets backends of `apache-airflow-providers-amazon` prior to 9.28.0, the team-scoping logic could resolve a `conn_id` containing a `/` (e.g. `"my_team/conn"`) to the same path as another team's team-scoped secret when the caller had no team context. A privileged caller without team context could therefore retrieve another team's secret by crafting a colliding `conn_id`. Fixed in 9.28.0 by switching the team-scope separator to `--` and rejecting team-shaped `conn_id`s when team context is absent. Affects the experimental multi-tenant teams feature only. Users are recommended to upgrade to `apache-airflow-providers-amazon` 9.28.0, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-42526?

3 open source packages ship an affected version, including apache-airflow-providers-amazon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-amazon` | PyPI | All versions | 9.28.0 |
| `apache-airflow-providers-amazon` | PyPI | All versions | 9.28.0 |
| `apache-airflow-providers-amazon` | PyPI | All versions | 9.28.0 |

Products: Apache Apache-Airflow-Providers-Amazon.

## How do I fix CVE-2026-42526?

Upgrade apache-airflow-providers-amazon to 9.28.0 or later.

## Is CVE-2026-42526 being exploited?

There is no known exploitation of CVE-2026-42526 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Amazon provider

- [CVE-2023-25956](https://insights.sbomify.com/CVE-2023-25956/): Apache Airflow AWS Provider: Arbitrary file read via AWS provider (high 7.5)
- [CVE-2026-68872](https://insights.sbomify.com/CVE-2026-68872/): Missing authorization in Apache Airflow Amazon provider (medium 6.5)
- [CVE-2026-25604](https://insights.sbomify.com/CVE-2026-25604/): Apache Airflow AWS Auth Manager - Host Header Injection Leading to SAML Authentication Bypass (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42526 and fix it if it is affected.

What it is: CVE-2026-42526 is a medium-severity missing authorization vulnerability in Apache Airflow Amazon provider, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42526 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 9.28.0
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 9.28.0
- apache-airflow-providers-amazon (PyPI): affected all versions; fixed in 9.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42526/ (Markdown: https://insights.sbomify.com/CVE-2026-42526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42526
- OSV: https://osv.dev/vulnerability/CVE-2026-42526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42526/
Summaries are generated and may contain mistakes; the official description above is the record.
