CVE-2026-42527 Apache Camel: Permissive default ObjectInputFilter pattern admits java.net.** and enables DNS-based information disclosure
Attackers can trigger DNS queries via deserialized Java objects in Apache Camel, enabling out-of-band information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42527?
CVE-2026-42527 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Deserialization of Untrusted Data vulnerability in Apache Camel.
The default ObjectInputFilter pattern shipped with several Apache Camel components for defense-in-depth deserialization filtering ('java.**;javax.**;org.apache.camel.**;!*', or the no-'javax.**' variant in the aggregation-repository components) uses a recursive 'java.**' glob that admits classes whose hashCode/equals/readObject methods perform network I/O, notably java.net.URL and java.net.InetAddress. When an attacker can deliver a Java-serialized payload to an affected Camel consumer, deserialization of a HashMap (or any collection that calls hashCode on its elements) containing java.net.URL keys causes the JVM to issue DNS queries to the attacker-supplied host during the deserialization side-effect. The class-level filter check passes because the resulting object's class (HashMap) is allow-listed; the DNS query is observable on an attacker-controlled DNS server, providing an out-of-band side channel. The exposure is highest on the camel-jms family because JmsBinding.extractBodyFromJms invokes ObjectMessage.getObject() unconditionally when mapJmsMessage=true (default). Affected components: camel-jms, camel-sjms, camel-amqp, camel-mina, camel-netty, camel-netty-http, camel-vertx-http, camel-infinispan, and the aggregation repository components camel-leveldb, camel-cassandraql, camel-consul, camel-sql (JDBC aggregation repository). This issue affects Apache Camel: from 4.14.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.
Users are recommended to upgrade to a version that contains the CAMEL-23372 fix once available: 4.21.0 for the 4.21.x line, 4.18.3 for the 4.18.x line, and 4.14.8 for the 4.14.x line. For deployments that cannot upgrade immediately, configure a JMS-provider-side allow-list (Apache ActiveMQ Artemis 'deserializationAllowList' / 'deserializationDenyList', Apache ActiveMQ Classic 'org.apache.activemq.SERIALIZABLE_PACKAGES') as the primary mitigation, and/or override the in-code default via the endpoint-level 'deserializationFilter' option or the JVM-wide '-Djdk.serialFilter' system property with an explicit deny: '!java.net.**;java.**;javax.**;org.apache.camel.**;!*' (or '!java.net.**;java.**;org.apache.camel.**;!*' for the aggregation-repository components, which do not include javax.**).
Weakness: CWE-502
Which versions are affected by CVE-2026-42527?
40 open source packages ship an affected version, including org.apache.camel:camel-amqp, org.apache.camel:camel-cassandraql and org.apache.camel:camel-consul. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-amqp Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-amqp Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-amqp Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-amqp Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-amqp Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-amqp Maven | From 4.19.0 | 4.21.0 |
34 more packages
org.apache.camel:camel-cassandraql Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-cassandraql Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-cassandraql Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-cassandraql Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-cassandraql Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-cassandraql Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-consul Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-consul Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-consul Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-consul Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-consul Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-consul Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-infinispan Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-infinispan Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-infinispan Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-infinispan Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-infinispan Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-infinispan Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-jms Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-jms Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-jms Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-jms Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-jms Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-jms Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-leveldb Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-leveldb Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-leveldb Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-leveldb Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-leveldb Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-leveldb Maven | From 4.19.0 | 4.21.0 |
org.apache.camel:camel-mina Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-mina Maven | From 4.14.0 | 4.14.8 |
org.apache.camel:camel-mina Maven | From 4.18.0 | 4.18.3 |
org.apache.camel:camel-mina Maven | From 4.18.0 | 4.18.3 |
Products include Apache Camel.
How do I fix CVE-2026-42527?
Upgrade org.apache.camel:camel-amqp to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-42527 being exploited?
There is no known exploitation of CVE-2026-42527 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-8h6p-jvhf-9hcr, MINI-cgfr-mrgw-5c69, MINI-hcc3-6rqw-rcfv.