CVE-2026-42528 Apache HTTP Server: mod_dav shared lock overflow
An attacker with WebDAV lock permissions can crash Apache server child processes due to a memory calculation bug in mod_dav.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42528?
CVE-2026-42528 is a medium-severity vulnerability in Apache Http Server, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A memory calculation bug in mod_dav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes.
Users are recommended to upgrade to version 2.4.69, which fixes this issue
Weakness: CWE-789
Which versions are affected by CVE-2026-42528?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.69 |
Products include Apache Http Server.
How do I fix CVE-2026-42528?
Upgrade apache to 2.4.69 or later.
Is CVE-2026-42528 being exploited?
There is no known exploitation of CVE-2026-42528 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-42528, AZL-106773, BELL-CVE-2026-42528, BIT-apache-2026-42528, DEBIAN-CVE-2026-42528, ECHO-5aa6-ecfa-0fc3 and 3 more.