{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 4 products.","exploited":"There is no known exploitation of CVE-2026-42530 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.31.2 or later.","what":"CVE-2026-42530 is a critical use after free vulnerability in F5 NGINX Open Source, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42530 and fix it if it is affected.\n\nWhat it is: CVE-2026-42530 is a critical use after free vulnerability in F5 NGINX Open Source, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42530 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 1.31.0; fixed in 1.31.2\n- nginx-gateway (Bitnami): affected from 1.31.0; fixed in 1.31.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42530/ (Markdown: https://insights.sbomify.com/CVE-2026-42530/index.md)","id":"CVE-2026-42530","markdown":"https://insights.sbomify.com/CVE-2026-42530/index.md","name":"CVE-2026-42530","record":{"aliases":["BIT-nginx-2026-42530","BIT-nginx-gateway-2026-42530","GHSA-5mcp-3252-f5vr","MINI-4mcp-m74h-7cw4"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"Remote attackers can trigger a use-after-free in NGINX HTTP/3 module causing crashes or code execution if ASLR is bypassed.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_gateway_fabric","vendor":"f5"},{"product":"nginx_ingress_controller","vendor":"f5"},{"product":"nginx_instance_manager","vendor":"f5"},{"product":"nginx_open_source","vendor":"f5"}],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"NGINX Open Source has a vulnerability in the ngx_http_v3_module module. When NGINX Open Source is configured to use the HTTP/3 QUIC module, a remote unauthenticated attacker along with conditions beyond their control can use a specially crafted HTTP/3 session to reopen a QPACK encoder stream. This may cause a Use-after-Free in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.  \n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-06-19","github_poc":3,"max_poc_stars":5,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-19T19:23:58Z","kind":"github_poc","ref":"https://github.com/v4ltonn/CVE-2026-42530","stars":5,"title":"Scanner PoC for CVE-2026-42530 -- nginx 1.31.0-1.31.1 HTTP/3 QPACK encoder stream Use-After-Free (CVSS 9.2)"},{"date":"2026-06-19T20:28:17Z","kind":"github_poc","ref":"https://github.com/0xredash/CVE-2026-42530","stars":3,"title":"CVE-2026-42530"},{"date":"2026-06-19T01:04:03Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-2026-42530","stars":0,"title":"CVE-2026-42530 - Draft"}],"tier":"poc_unverified"},"has_fix":true,"headline":"NGINX Open-Source ngx_http_v3_module vulnerability","id":"CVE-2026-42530","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in visidata","id":"CVE-2026-42532"},"packages":[{"ecosystem":"Bitnami","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2026-42530"},{"ecosystem":"Bitnami","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2026-42530"}],"prev":{"headline":"Apache HTTP Server: mod_dav shared lock overflow","id":"CVE-2026-42528"},"products":["NGINX Open Source"],"published":"2026-06-17","related":[{"cvss_score":9.2,"headline":"NGINX Map directive and Regex matching vulnerability","id":"CVE-2026-42533","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.8,"headline":"NGINX ngx_http_slice_module vulnerability","id":"CVE-2026-60005","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-11311","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.6,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-50107","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.3,"headline":"NGINX ngx_http_ssi_module vulnerability","id":"CVE-2026-56434","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.2,"headline":"NGINX vulnerability","id":"CVE-2026-1642","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-16","vendors":["F5"]},"summary":"Remote attackers can trigger a use-after-free in NGINX HTTP/3 module causing crashes or code execution if ASLR is bypassed.","url":"https://insights.sbomify.com/CVE-2026-42530/"}