# CVE-2026-42530: NGINX Open-Source ngx_http_v3_module vulnerability

> Remote attackers can trigger a use-after-free in NGINX HTTP/3 module causing crashes or code execution if ASLR is bypassed.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 16 Jul 2026
- **Also known as:** BIT-nginx-2026-42530, BIT-nginx-gateway-2026-42530, GHSA-5mcp-3252-f5vr, MINI-4mcp-m74h-7cw4

## What is CVE-2026-42530?

CVE-2026-42530 is a critical use after free vulnerability in F5 NGINX Open Source, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NGINX Open Source has a vulnerability in the ngx_http_v3_module module. When NGINX Open Source is configured to use the HTTP/3 QUIC module, a remote unauthenticated attacker along with conditions beyond their control can use a specially crafted HTTP/3 session to reopen a QPACK encoder stream. This may cause a Use-after-Free in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.  

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-42530?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.31.0 | 1.31.2 |
| `nginx-gateway` | Bitnami | From 1.31.0 | 1.31.2 |

Products: F5 Nginx Gateway Fabric, F5 Nginx Ingress Controller, F5 Nginx Instance Manager, F5 Nginx Open Source.

## How do I fix CVE-2026-42530?

Upgrade nginx to 1.31.2 or later.

## Is CVE-2026-42530 being exploited?

There is no known exploitation of CVE-2026-42530 in the wild and no public exploit code.

Public exploit code:

- Scanner PoC for CVE-2026-42530 -- nginx 1.31.0-1.31.1 HTTP/3 QPACK encoder stream Use-After-Free (CVSS 9.2) (github_poc): https://github.com/v4ltonn/CVE-2026-42530
- CVE-2026-42530 (github_poc): https://github.com/0xredash/CVE-2026-42530
- CVE-2026-42530 - Draft (github_poc): https://github.com/HORKimhab/CVE-2026-42530

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-42533](https://insights.sbomify.com/CVE-2026-42533/): NGINX Map directive and Regex matching vulnerability (critical 9.2)
- [CVE-2026-60005](https://insights.sbomify.com/CVE-2026-60005/): NGINX ngx_http_slice_module vulnerability (high 8.8)
- [CVE-2026-11311](https://insights.sbomify.com/CVE-2026-11311/): NGINX Gateway Fabric vulnerability (high 8.6)
- [CVE-2026-50107](https://insights.sbomify.com/CVE-2026-50107/): NGINX Gateway Fabric vulnerability (high 8.6)
- [CVE-2026-56434](https://insights.sbomify.com/CVE-2026-56434/): NGINX ngx_http_ssi_module vulnerability (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42530 and fix it if it is affected.

What it is: CVE-2026-42530 is a critical use after free vulnerability in F5 NGINX Open Source, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42530 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.31.0; fixed in 1.31.2
- nginx-gateway (Bitnami): affected from 1.31.0; fixed in 1.31.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42530/ (Markdown: https://insights.sbomify.com/CVE-2026-42530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42530
- OSV: https://osv.dev/vulnerability/CVE-2026-42530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42530/
Summaries are generated and may contain mistakes; the official description above is the record.
