CVE-2026-42536 Apache HTTP Server: mod_xml2enc heap overflow
Heap overflow in Apache HTTP Server's mod_xml2enc allows attackers to execute arbitrary code or cause denial of service via untrusted content.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-42536?
CVE-2026-42536 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
Which versions are affected by CVE-2026-42536?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.68 |
Products include Apache Http Server.
How do I fix CVE-2026-42536?
Upgrade apache to 2.4.68 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-42536 being exploited?
There is no known exploitation of CVE-2026-42536 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-42536, AZL-89726, BELL-CVE-2026-42536, BIT-apache-2026-42536, CLSA-2026-1782299145, DEBIAN-CVE-2026-42536 and 4 more.