{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-42536 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.68 or later.","what":"CVE-2026-42536 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42536 and fix it if it is affected.\n\nWhat it is: CVE-2026-42536 is a high-severity memory corruption vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42536 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.68\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42536/ (Markdown: https://insights.sbomify.com/CVE-2026-42536/index.md)","id":"CVE-2026-42536","markdown":"https://insights.sbomify.com/CVE-2026-42536/index.md","name":"CVE-2026-42536","record":{"aliases":["ALPINE-CVE-2026-42536","AZL-89726","BELL-CVE-2026-42536","BIT-apache-2026-42536","CLSA-2026-1782299145","DEBIAN-CVE-2026-42536","ECHO-de1d-293d-295d","GHSA-2p7m-6jhq-26cm","MINI-vrcf-3j64-wp2r","UBUNTU-CVE-2026-42536"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Heap overflow in Apache HTTP Server's mod_xml2enc allows attackers to execute arbitrary code or cause denial of service via untrusted content.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content\n\nThis issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.\n\nUsers are recommended to upgrade to version 2.4.68, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-09-13","github_poc":1,"max_poc_stars":6,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-13T18:53:32Z","kind":"github_poc","ref":"https://github.com/erberkan/CVE-2026-42536-PoC","stars":6,"title":"Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache HTTP Server: mod_xml2enc heap overflow","id":"CVE-2026-42536","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache Ranger: Remote Code Execution via JDBC URL Injection","id":"CVE-2026-42537"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.68"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2026-42536"}],"prev":{"headline":"Apache HTTP Server: mod_dav_fs protected directory access","id":"CVE-2026-42535"},"products":["Apache HTTP Server"],"published":"2026-06-08","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["Apache Software Foundation"]},"summary":"Heap overflow in Apache HTTP Server's mod_xml2enc allows attackers to execute arbitrary code or cause denial of service via untrusted content.","url":"https://insights.sbomify.com/CVE-2026-42536/"}