{"answers":{"affected":"2 open source packages ship an affected version, including flightphp/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42548 exists.","fix":"Upgrade flightphp/core to 3.18.1 or later.","what":"CVE-2026-42548 is a high-severity cross-site scripting vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42548 and fix it if it is affected.\n\nWhat it is: CVE-2026-42548 is a high-severity cross-site scripting vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42548 exists.\n\nAffected packages and fixed versions:\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42548/ (Markdown: https://insights.sbomify.com/CVE-2026-42548/index.md)","id":"CVE-2026-42548","markdown":"https://insights.sbomify.com/CVE-2026-42548/index.md","name":"CVE-2026-42548","record":{"aliases":["GHSA-fcx8-ph5r-mxr4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP micro-framework","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in the victim's browser via unvalidated JSONP callback parameters in the Flight PHP framework.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Flight::jsonp() concatenates the ?jsonp= query parameter directly into an application/javascript response body without validating that the value is a legal JavaScript identifier. An attacker can inject arbitrary JavaScript that executes in the response origin, enabling reflected cross-site scripting. This vulnerability is fixed in 3.18.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flight: Reflected XSS via unvalidated JSONP callback in Flight::jsonp()","id":"CVE-2026-42548","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Flight: Path traversal in `make:controller` CLI creates arbitrary directories outside project root","id":"CVE-2026-42549"},"packages":[{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":null,"source":"GHSA-fcx8-ph5r-mxr4"},{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":"pkg:composer/flightphp/core","source":"GHSA-fcx8-ph5r-mxr4"}],"prev":{"headline":"IRIS Alerts Can be Falsely Attributed to Customers","id":"CVE-2026-42547"},"products":["core"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["flightphp"]},"summary":"Attackers can execute arbitrary JavaScript in the victim's browser via unvalidated JSONP callback parameters in the Flight PHP framework.","url":"https://insights.sbomify.com/CVE-2026-42548/"}