# CVE-2026-42548: Flight: Reflected XSS via unvalidated JSONP callback in Flight::jsonp()

> Attackers can execute arbitrary JavaScript in the victim's browser via unvalidated JSONP callback parameters in the Flight PHP framework.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-fcx8-ph5r-mxr4

## What is CVE-2026-42548?

CVE-2026-42548 is a high-severity cross-site scripting vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Flight::jsonp() concatenates the ?jsonp= query parameter directly into an application/javascript response body without validating that the value is a legal JavaScript identifier. An attacker can inject arbitrary JavaScript that executes in the response origin, enabling reflected cross-site scripting. This vulnerability is fixed in 3.18.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-42548?

2 open source packages ship an affected version, including flightphp/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flightphp/core` | Packagist | All versions | 3.18.1 |
| `flightphp/core` | Packagist | All versions | 3.18.1 |

## How do I fix CVE-2026-42548?

Upgrade flightphp/core to 3.18.1 or later.

## Is CVE-2026-42548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42548 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42548 and fix it if it is affected.

What it is: CVE-2026-42548 is a high-severity cross-site scripting vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42548 exists.

Affected packages and fixed versions:
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42548/ (Markdown: https://insights.sbomify.com/CVE-2026-42548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42548
- OSV: https://osv.dev/vulnerability/CVE-2026-42548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42548/
Summaries are generated and may contain mistakes; the official description above is the record.
