# CVE-2026-42549: Flight: Path traversal in `make:controller` CLI creates arbitrary directories outside project root

> Attackers can create arbitrary directories outside the project root via path traversal in the make:controller CLI command.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-3xjv-pmf2-gf2q

## What is CVE-2026-42549?

CVE-2026-42549 is a medium-severity path traversal vulnerability in flightphp core, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, the make:controller CLI command calls mkdir(..., recursive: true) on a path built from the user-supplied controller name, before Nette's class-name validation runs. The class-file write is correctly rejected by Nette when the name contains /, but the recursive directory creation side effect is already committed — including directories located outside the project root through ../ traversal. This vulnerability is fixed in 3.18.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-42549?

2 open source packages ship an affected version, including flightphp/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flightphp/core` | Packagist | All versions | 3.18.1 |
| `flightphp/core` | Packagist | All versions | 3.18.1 |

## How do I fix CVE-2026-42549?

Upgrade flightphp/core to 3.18.1 or later.

## Is CVE-2026-42549 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42549 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42549 and fix it if it is affected.

What it is: CVE-2026-42549 is a medium-severity path traversal vulnerability in flightphp core, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42549 exists.

Affected packages and fixed versions:
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42549/ (Markdown: https://insights.sbomify.com/CVE-2026-42549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42549
- OSV: https://osv.dev/vulnerability/CVE-2026-42549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42549/
Summaries are generated and may contain mistakes; the official description above is the record.
