{"answers":{"affected":"2 open source packages ship an affected version, including flightphp/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42550 exists.","fix":"Upgrade flightphp/core to 3.18.1 or later.","what":"CVE-2026-42550 is a high-severity SQL injection vulnerability in flightphp core, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42550 and fix it if it is affected.\n\nWhat it is: CVE-2026-42550 is a high-severity SQL injection vulnerability in flightphp core, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42550 exists.\n\nAffected packages and fixed versions:\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42550/ (Markdown: https://insights.sbomify.com/CVE-2026-42550/index.md)","id":"CVE-2026-42550","markdown":"https://insights.sbomify.com/CVE-2026-42550/index.md","name":"CVE-2026-42550","record":{"aliases":["GHSA-xwqr-rcqg-22mr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP micro-framework","requires_auth":"low_privilege","summary":"Attackers can inject arbitrary SQL via malicious array keys in Flight framework database operations, potentially reading or modifying data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Flight is an extensible micro-framework for PHP. Prior to 3.18.1, SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db-\u003einsert('users', $request-\u003edata-\u003egetData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. This vulnerability is fixed in 3.18.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flight: SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete","id":"CVE-2026-42550","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core","id":"CVE-2026-42551"},"packages":[{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":null,"source":"GHSA-xwqr-rcqg-22mr"},{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":"pkg:composer/flightphp/core","source":"GHSA-xwqr-rcqg-22mr"}],"prev":{"headline":"Flight: Path traversal in `make:controller` CLI creates arbitrary directories outside project root","id":"CVE-2026-42549"},"products":["core"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["flightphp"]},"summary":"Attackers can inject arbitrary SQL via malicious array keys in Flight framework database operations, potentially reading or modifying data.","url":"https://insights.sbomify.com/CVE-2026-42550/"}