# CVE-2026-42550: Flight: SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete

> Attackers can inject arbitrary SQL via malicious array keys in Flight framework database operations, potentially reading or modifying data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-xwqr-rcqg-22mr

## What is CVE-2026-42550?

CVE-2026-42550 is a high-severity SQL injection vulnerability in flightphp core, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db->insert('users', $request->data->getData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. This vulnerability is fixed in 3.18.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-42550?

2 open source packages ship an affected version, including flightphp/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flightphp/core` | Packagist | All versions | 3.18.1 |
| `flightphp/core` | Packagist | All versions | 3.18.1 |

## How do I fix CVE-2026-42550?

Upgrade flightphp/core to 3.18.1 or later.

## Is CVE-2026-42550 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42550 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42550 and fix it if it is affected.

What it is: CVE-2026-42550 is a high-severity SQL injection vulnerability in flightphp core, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42550 exists.

Affected packages and fixed versions:
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42550/ (Markdown: https://insights.sbomify.com/CVE-2026-42550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42550
- OSV: https://osv.dev/vulnerability/CVE-2026-42550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42550/
Summaries are generated and may contain mistakes; the official description above is the record.
