{"answers":{"affected":"2 open source packages ship an affected version, including flightphp/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42551 exists.","fix":"Upgrade flightphp/core to 3.18.1 or later.","what":"CVE-2026-42551 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42551 and fix it if it is affected.\n\nWhat it is: CVE-2026-42551 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42551 exists.\n\nAffected packages and fixed versions:\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42551/ (Markdown: https://insights.sbomify.com/CVE-2026-42551/index.md)","id":"CVE-2026-42551","markdown":"https://insights.sbomify.com/CVE-2026-42551/index.md","name":"CVE-2026-42551","record":{"aliases":["GHSA-vxrr-w42w-w76g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP micro-framework","requires_auth":"none","summary":"Flight PHP framework allows HTTP method override by default, enabling CSRF escalation and middleware bypass in GET requests.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Request::getMethod() unconditionally honors the X-HTTP-Method-Override header and the $_REQUEST['_method'] parameter on any HTTP verb (including safe verbs such as GET), with no opt-in and no whitelist of permitted target methods. A GET request can silently become a DELETE or PUT, enabling CSRF escalation against destructive endpoints, bypass of middleware gated on unsafe verbs, and cache poisoning between CDN and origin. This vulnerability is fixed in 3.18.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core","id":"CVE-2026-42551","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Flight: Sensitive information disclosure via default error handler in flightphp/core","id":"CVE-2026-42552"},"packages":[{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":null,"source":"GHSA-vxrr-w42w-w76g"},{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":"pkg:composer/flightphp/core","source":"GHSA-vxrr-w42w-w76g"}],"prev":{"headline":"Flight: SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete","id":"CVE-2026-42550"},"products":["core"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["flightphp"]},"summary":"Flight PHP framework allows HTTP method override by default, enabling CSRF escalation and middleware bypass in GET requests.","url":"https://insights.sbomify.com/CVE-2026-42551/"}