# CVE-2026-42551: Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core

> Flight PHP framework allows HTTP method override by default, enabling CSRF escalation and middleware bypass in GET requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-vxrr-w42w-w76g

## What is CVE-2026-42551?

CVE-2026-42551 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Request::getMethod() unconditionally honors the X-HTTP-Method-Override header and the $_REQUEST['_method'] parameter on any HTTP verb (including safe verbs such as GET), with no opt-in and no whitelist of permitted target methods. A GET request can silently become a DELETE or PUT, enabling CSRF escalation against destructive endpoints, bypass of middleware gated on unsafe verbs, and cache poisoning between CDN and origin. This vulnerability is fixed in 3.18.1.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-42551?

2 open source packages ship an affected version, including flightphp/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flightphp/core` | Packagist | All versions | 3.18.1 |
| `flightphp/core` | Packagist | All versions | 3.18.1 |

## How do I fix CVE-2026-42551?

Upgrade flightphp/core to 3.18.1 or later.

## Is CVE-2026-42551 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42551 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42551 and fix it if it is affected.

What it is: CVE-2026-42551 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42551 exists.

Affected packages and fixed versions:
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42551/ (Markdown: https://insights.sbomify.com/CVE-2026-42551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42551
- OSV: https://osv.dev/vulnerability/CVE-2026-42551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42551/
Summaries are generated and may contain mistakes; the official description above is the record.
