{"answers":{"affected":"2 open source packages ship an affected version, including flightphp/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42552 exists.","fix":"Upgrade flightphp/core to 3.18.1 or later.","what":"CVE-2026-42552 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42552 and fix it if it is affected.\n\nWhat it is: CVE-2026-42552 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42552 exists.\n\nAffected packages and fixed versions:\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n- flightphp/core (Packagist): affected all versions; fixed in 3.18.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42552/ (Markdown: https://insights.sbomify.com/CVE-2026-42552/index.md)","id":"CVE-2026-42552","markdown":"https://insights.sbomify.com/CVE-2026-42552/index.md","name":"CVE-2026-42552","record":{"aliases":["GHSA-qrch-52m5-vv85"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP micro-framework","requires_auth":"none","summary":"The default error handler leaks stack traces and internal paths in HTTP 500 responses, exposing sensitive data to attackers.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Flight is an extensible micro-framework for PHP. Prior to 3.18.1, the default error handler Engine::_error() writes the full exception message, exception code, and stack trace (including absolute filesystem paths) directly into the HTTP 500 response, with no debug gating. Production deployments leak internal paths, any secret interpolated into an exception message, and full module structure — giving attackers primitives for chaining other weaknesses (LFI, path traversal). This vulnerability is fixed in 3.18.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flight: Sensitive information disclosure via default error handler in flightphp/core","id":"CVE-2026-42552","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Cinny: Access token disclosure via invalidated emoji pack avatar URL in service worker","id":"CVE-2026-42553"},"packages":[{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":null,"source":"GHSA-qrch-52m5-vv85"},{"ecosystem":"Packagist","fixed":["3.18.1"],"introduced":["0"],"last_affected":[],"package":"flightphp/core","purl":"pkg:composer/flightphp/core","source":"GHSA-qrch-52m5-vv85"}],"prev":{"headline":"Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core","id":"CVE-2026-42551"},"products":["core"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["flightphp"]},"summary":"The default error handler leaks stack traces and internal paths in HTTP 500 responses, exposing sensitive data to attackers.","url":"https://insights.sbomify.com/CVE-2026-42552/"}