# CVE-2026-42552: Flight: Sensitive information disclosure via default error handler in flightphp/core

> The default error handler leaks stack traces and internal paths in HTTP 500 responses, exposing sensitive data to attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-qrch-52m5-vv85

## What is CVE-2026-42552?

CVE-2026-42552 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, the default error handler Engine::_error() writes the full exception message, exception code, and stack trace (including absolute filesystem paths) directly into the HTTP 500 response, with no debug gating. Production deployments leak internal paths, any secret interpolated into an exception message, and full module structure — giving attackers primitives for chaining other weaknesses (LFI, path traversal). This vulnerability is fixed in 3.18.1.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-42552?

2 open source packages ship an affected version, including flightphp/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flightphp/core` | Packagist | All versions | 3.18.1 |
| `flightphp/core` | Packagist | All versions | 3.18.1 |

## How do I fix CVE-2026-42552?

Upgrade flightphp/core to 3.18.1 or later.

## Is CVE-2026-42552 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42552 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42552 and fix it if it is affected.

What it is: CVE-2026-42552 is a high-severity vulnerability in flightphp core, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42552 exists.

Affected packages and fixed versions:
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1
- flightphp/core (Packagist): affected all versions; fixed in 3.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42552/ (Markdown: https://insights.sbomify.com/CVE-2026-42552/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42552
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42552
- OSV: https://osv.dev/vulnerability/CVE-2026-42552

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42552/
Summaries are generated and may contain mistakes; the official description above is the record.
