CVE-2026-42556 Postiz stored XSS in public preview page

High 8.9 Published Updated

Authenticated users can inject malicious HTML into post previews, leading to stored XSS and potential account takeover when victims view the link.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-42556?

CVE-2026-42556 is a high-severity cross-site scripting vulnerability in gitroomhq postiz-app, published on 8 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Postiz is an AI social media scheduling tool. From version 2.21.6 to before version 2.21.7, any authenticated user who can create a post can store arbitrary HTML in post content by tampering their own save request and send the public preview link /p/<postId>?share=true to another user. The preview page renders that stored HTML with dangerouslySetInnerHTML on the main application origin. This issue has been patched in version 2.21.7.

Weakness: CWE-79

Which versions are affected by CVE-2026-42556?

It affects 1 product.

Products include Gitroom Postiz.

How do I fix CVE-2026-42556?

No fix has been published for CVE-2026-42556 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-42556 being exploited?

There is no known exploitation of CVE-2026-42556 in the wild and no public exploit code.

Sources

Also known as GHSA-hhxq-3wg7-4rj8.

Is CVE-2026-42556 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free