# CVE-2026-42558: Xibo Vulnerable to Stored XSS and Iframe Sandbox Escape via Data Connector Script in DataSet

> Authorized users with specific DataSet privileges can exploit stored XSS and iframe sandbox escape to execute arbitrary code or bypass security controls.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-6389-j56c-9fww

## What is CVE-2026-42558?

CVE-2026-42558 is a high-severity cross-site scripting vulnerability in xibosignage xibo-cms, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Xibo is an open source digital signage platform with a web content management system and Windows display player software. Prior to 4.4.2, a vulnerability chain consisting of Stored XSS and Iframe Sandbox escape in the Xibo CMS allows users with DataSet permissions to use the Data Connector functionality to craft messages which escape the sandbox and facilitate XSS. Exploitation of the vulnerability is possible on behalf of an authorized user who has both of the following privileges, which are not granted to non-admins as standard: Include "Add DataSet" button to allow for additional DataSets to be created independently to Layouts Users should upgrade to version 4.4.2 which fixes this issue. Upgrading to a fixed version is necessary to remediate. Users unable to upgrade should revoke such privileges from users they do not trust.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-346 (Origin Validation Error), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-42558?


## How do I fix CVE-2026-42558?

No fix has been published for CVE-2026-42558 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42558 being exploited?

There is no known exploitation of CVE-2026-42558 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42558 and fix it if it is affected.

What it is: CVE-2026-42558 is a high-severity cross-site scripting vulnerability in xibosignage xibo-cms, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-42558 in the wild and no public exploit code.

Affected product: xibosignage xibo-cms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42558/ (Markdown: https://insights.sbomify.com/CVE-2026-42558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42558
- OSV: https://osv.dev/vulnerability/CVE-2026-42558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42558/
Summaries are generated and may contain mistakes; the official description above is the record.
