# CVE-2026-42561: Python-Multipart: Denial of Service via unbounded multipart part headers

> An attacker can cause denial of service in applications using Python-Multipart by sending requests with excessive or oversized multipart headers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 7 Aug 2026
- **Also known as:** CLEANSTART-2026-SC26416, CLSA-2026-1783904617, DEBIAN-CVE-2026-42561, ECHO-6701-0c72-de60, GHSA-pp6c-gr5w-3c5g, MINI-4hf2-jvm5-g9mq, MINI-8vqp-hpc7-wcv8, MINI-cvrr-36pw-82cm, MINI-jg6x-g7p5-39h6, MINI-m2fw-g9gx-cvfv, MINI-p2m2-rcq4-4v8q, MINI-rjm8-5qv7-7m96, MINI-wc7r-vx28-w35p, PYSEC-2026-3039, ROOT-APP-PYPI-CVE-2026-42561, UBUNTU-CVE-2026-42561, openSUSE-SU-2026:10797-1

## What is CVE-2026-42561?

CVE-2026-42561 is a high-severity denial of service vulnerability in Kludex python-multipart, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python-Multipart is a streaming multipart parser for Python. Prior to 0.0.27, python-multipart has a denial of service vulnerability in multipart part header parsing. When parsing multipart/form-data, MultipartParser previously had no limit on the number of part headers or the size of an individual part header. An attacker could send a request with either many repeated headers without terminating the header block or a single very large header value, causing excessive CPU work before request rejection or completion. This vulnerability is fixed in 0.0.27.

Weakness: CWE-606 (Unchecked Input for Loop Condition), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-42561?

3 open source packages ship an affected version, including python-multipart.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-multipart` | PyPI | All versions | 0.0.27 |
| `python-multipart` | PyPI | All versions | 0.0.27 |
| `python-multipart` | PyPI | All versions | 0.0.27 |
| `python-python-multipart` | openSUSE:Tumbleweed | All versions | 0.0.28-1.1 |

## How do I fix CVE-2026-42561?

Upgrade python-multipart to 0.0.27 or later.

## Is CVE-2026-42561 being exploited?

There is no known exploitation of CVE-2026-42561 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42561 and fix it if it is affected.

What it is: CVE-2026-42561 is a high-severity denial of service vulnerability in Kludex python-multipart, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42561 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-multipart (PyPI): affected all versions; fixed in 0.0.27
- python-multipart (PyPI): affected all versions; fixed in 0.0.27
- python-multipart (PyPI): affected all versions; fixed in 0.0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42561/ (Markdown: https://insights.sbomify.com/CVE-2026-42561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42561
- OSV: https://osv.dev/vulnerability/CVE-2026-42561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42561/
Summaries are generated and may contain mistakes; the official description above is the record.
