# CVE-2026-42562: Plainpad: Privilege Escalation via Writable Admin Field in Profile Update (Access Control)

> Low-privilege users can escalate to administrator by modifying their profile, granting access to admin-only features.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-pvfv-wvpm-q6f6

## What is CVE-2026-42562?

CVE-2026-42562 is a high-severity vulnerability in alextselegidis plainpad, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Plainpad is a self hosted note taking app. Prior to version 1.1.1, Plainpad allows a low-privilege authenticated user to self-escalate to administrator by submitting admin=true in PUT /api.php/v1/users/{id}. The endpoint directly persists the admin attribute from user input, and the escalated account can immediately access admin-only routes. This issue has been patched in version 1.1.1.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-42562?


## How do I fix CVE-2026-42562?

No fix has been published for CVE-2026-42562 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-42562 being exploited?

There is no known exploitation of CVE-2026-42562 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42562 and fix it if it is affected.

What it is: CVE-2026-42562 is a high-severity vulnerability in alextselegidis plainpad, published on 9 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42562 in the wild and no public exploit code.

Affected product: alextselegidis plainpad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42562/ (Markdown: https://insights.sbomify.com/CVE-2026-42562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42562
- OSV: https://osv.dev/vulnerability/CVE-2026-42562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42562/
Summaries are generated and may contain mistakes; the official description above is the record.
