{"answers":{"affected":"3 open source packages ship an affected version, including dulwich.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42563 exists.","fix":"Upgrade dulwich to 1.2.5 or later.","what":"CVE-2026-42563 is a high-severity command injection vulnerability in jelmer dulwich, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-42563 and fix it if it is affected.\n\nWhat it is: CVE-2026-42563 is a high-severity command injection vulnerability in jelmer dulwich, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-42563 exists.\n\nAffected packages and fixed versions:\n- dulwich (PyPI): affected from 0.24.0; fixed in 1.2.5\n- dulwich (PyPI): affected from 0.24.0; fixed in 1.2.5\n- dulwich (PyPI): affected from 0.24.0; fixed in 1.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42563/ (Markdown: https://insights.sbomify.com/CVE-2026-42563/index.md)","id":"CVE-2026-42563","markdown":"https://insights.sbomify.com/CVE-2026-42563/index.md","name":"CVE-2026-42563","record":{"aliases":["CLEANSTART-2026-MJ32285","CLSA-2026-1781052734","DEBIAN-CVE-2026-42563","ECHO-b3a3-3b48-f3fe","GHSA-9277-mp7x-85jf","MINI-2p86-fr3m-g34v","PYSEC-2026-2464","ROOT-APP-PYPI-CVE-2026-42563","UBUNTU-CVE-2026-42563"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Git library","requires_auth":"none","summary":"Attackers can execute arbitrary commands by tricking users into merging malicious branches containing crafted file paths in Dulwich.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Dulwich is a pure-Python implementation of the Git file formats and protocols. Starting in version 0.24.0 and prior to version 1.2.5, Dulwich's `ProcessMergeDriver` substitutes the file path (from the git tree, controllable by an attacker via a malicious branch) into the merge driver command via the `%P` placeholder and executes it with `subprocess.run(..., shell=True)`. An attacker who can cause a victim to merge an untrusted branch can achieve arbitrary command execution by crafting malicious file paths. Version 1.2.5 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Dulwich Vulnerable to Command Injection via Merge Driver Path","id":"CVE-2026-42563","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"jotty·page: Unauthenticated Path Traversal leads to sensitive file disclosure and session-token reuse impact","id":"CVE-2026-42564"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.5"],"introduced":["0.24.0"],"last_affected":[],"package":"dulwich","purl":null,"source":"GHSA-9277-mp7x-85jf"},{"ecosystem":"PyPI","fixed":["1.2.5"],"introduced":["0.24.0"],"last_affected":[],"package":"dulwich","purl":"pkg:pypi/dulwich","source":"GHSA-9277-mp7x-85jf"},{"ecosystem":"PyPI","fixed":["1.2.5"],"introduced":["0.24.0"],"last_affected":[],"package":"dulwich","purl":"pkg:pypi/dulwich","source":"PYSEC-2026-2464"}],"prev":{"headline":"Plainpad: Privilege Escalation via Writable Admin Field in Profile Update (Access Control)","id":"CVE-2026-42562"},"products":["dulwich"],"published":"2026-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-12","vendors":["jelmer"]},"summary":"Attackers can execute arbitrary commands by tricking users into merging malicious branches containing crafted file paths in Dulwich.","url":"https://insights.sbomify.com/CVE-2026-42563/"}