{"answers":{"affected":"2 open source packages ship an affected version, including org.yamcs:yamcs-core.","exploited":"There is no known exploitation of CVE-2026-42568 in the wild and no public exploit code.","fix":"Upgrade org.yamcs:yamcs-core to 5.12.7 or later.","what":"CVE-2026-42568 is a medium-severity vulnerability in yamcs, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-42568 and fix it if it is affected.\n\nWhat it is: CVE-2026-42568 is a medium-severity vulnerability in yamcs, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-42568 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7\n- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-42568/ (Markdown: https://insights.sbomify.com/CVE-2026-42568/index.md)","id":"CVE-2026-42568","markdown":"https://insights.sbomify.com/CVE-2026-42568/index.md","name":"CVE-2026-42568","record":{"aliases":["GHSA-cqh3-jg8p-336j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Mission control framework","requires_auth":"low_privilege","summary":"Attackers can inject LDAP queries via username to bypass authentication or read data in Yamcs mission control.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-90","name":"Improper Neutralization of Special Elements used in an LDAP Query"}],"description":"Yamcs is a mission control framework. Prior to versions 5.13.0 and 5.12.7, an LDAP injection vulnerability exists in `org.yamcs.security.LdapAuthModule` when constructing search filters. The username parameter is inserted directly into the LDAP filter without proper RFC 4515 escaping. Versions 5.13.0 and 5.12.7 patch the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2026-05-29","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-29T14:35:29Z","kind":"github_poc","ref":"https://github.com/ex-cal1bur/CVE-2026-42568","stars":0,"title":"An LDAP injection vulnerability exists in org.yamcs.security.LdapAuthModule. The username parameter is inserted directly into LDAP search filters without RFC 4515 escaping, allowing authentication bypass."},{"date":"2026-05-30","kind":"exploitdb","ref":"52603","stars":null,"title":"YAMCS yamcs-core  5.12.7 - LDAP Injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Yamcs Vulnerable to LDAP Injection in LdapAuthModule","id":"CVE-2026-42568","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"phpvms: /importer authorization bypass causing full database wipe","id":"CVE-2026-42569"},"packages":[{"ecosystem":"Maven","fixed":["5.12.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":null,"source":"GHSA-cqh3-jg8p-336j"},{"ecosystem":"Maven","fixed":["5.12.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":"pkg:maven/org.yamcs/yamcs-core","source":"GHSA-cqh3-jg8p-336j"}],"prev":{"headline":"Svelte: ReDoS in `\u003csvelte:element\u003e` Tag Validation","id":"CVE-2026-42567"},"products":["yamcs"],"published":"2026-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-11","vendors":["yamcs"]},"summary":"Attackers can inject LDAP queries via username to bypass authentication or read data in Yamcs mission control.","url":"https://insights.sbomify.com/CVE-2026-42568/"}