# CVE-2026-42568: Yamcs Vulnerable to LDAP Injection in LdapAuthModule

> Attackers can inject LDAP queries via username to bypass authentication or read data in Yamcs mission control.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** GHSA-cqh3-jg8p-336j

## What is CVE-2026-42568?

CVE-2026-42568 is a medium-severity vulnerability in yamcs, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to versions 5.13.0 and 5.12.7, an LDAP injection vulnerability exists in `org.yamcs.security.LdapAuthModule` when constructing search filters. The username parameter is inserted directly into the LDAP filter without proper RFC 4515 escaping. Versions 5.13.0 and 5.12.7 patch the issue.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-42568?

2 open source packages ship an affected version, including org.yamcs:yamcs-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |

## How do I fix CVE-2026-42568?

Upgrade org.yamcs:yamcs-core to 5.12.7 or later.

## Is CVE-2026-42568 being exploited?

There is no known exploitation of CVE-2026-42568 in the wild and no public exploit code.

Public exploit code:

- An LDAP injection vulnerability exists in org.yamcs.security.LdapAuthModule. The username parameter is inserted directly into LDAP search filters without RFC 4515 escaping, allowing authentication bypass. (github_poc): https://github.com/ex-cal1bur/CVE-2026-42568
- YAMCS yamcs-core  5.12.7 - LDAP Injection (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-42568 and fix it if it is affected.

What it is: CVE-2026-42568 is a medium-severity vulnerability in yamcs, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-42568 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-42568/ (Markdown: https://insights.sbomify.com/CVE-2026-42568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-42568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-42568
- OSV: https://osv.dev/vulnerability/CVE-2026-42568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-42568/
Summaries are generated and may contain mistakes; the official description above is the record.
